Hi there 👋This is my solution for this challenge.
I will be very happy if you have any suggestions to improve my solution.
Thanks 😊
Hi there 👋This is my solution for this challenge.
I will be very happy if you have any suggestions to improve my solution.
Thanks 😊
Hello! Great solution
Here are my corrections
1.Use const on variables that don't change, in your case instead of let. 2.Use event.target.closest(".crew") to find the fastest graphic element with class "crew", instead of checking if event.target.classList has class "crew".
First project from site. This is a test to understand my knowledge about html and css basics world.
Hey!
Great solution
1.It is generally recommended to include scripts at the bottom of an HTML document, before the closing </body> tag. This is done so that the browser can first load the content of the page before loading and executing the scripts.
2-3.Use the same units of measure. Specify font-size in em.
4.Use for of instead of foreach
for (const currentItem of data) {
const summaryElement = document.getElementById(currentItem.category);
const summaryResultElement = summaryElement.querySelector('.result-number');
const summaryImageElement = summaryElement.querySelector('.result-typo .icon');
summaryResultElement.textContent = currentItem.score;
summaryImageElement.src = currentItem.icon;
}
Good luck! I hope I helped you
Hello there fellow developers👋 this challenges was wonderful✨, I really enjoyed using grid as I spent all the previous project using flex-box mainly as a tool to make layouts. I learned a lot about grid and I will continue learning and building strong foundation of CSS. I hope you like my solution, and tell me what you guys think? ♥
Hi!
Perfect solution
There are no comments, except for the empty alt attribute of the img tag.
Keep up the good work!
It was so fun doing this project I faced some challenges but I was able to solve them without any much of problems. I created this project in ReactJS, designing the front end using CSS and Tailwind CSS. Handling the state of the website with the help of React Context API. I hope you like my project.
Great work!
Here are some changes to your code
1.In the "filterItems" component, when the filterItems array changes, the component is completely re-rendered. To optimize rendering, you can use React.memo()
2.Using destructuring to get data. Instead of getting data from an object as a property and then using dot notation, you can use destructuring to get data directly into variables. This can increase the readability of the code and improve its maintainability. For example:
const [filterItems, setFilterItems] = useContext(ContextFilter);
Hope you find this feedback helpful!
Feedbacks are welcome.
Hi!!!
When I enter a number, the calculator does not remove the 0 at the beginning. fix it
Quite an enjoyable challenge. I have no idea how to make space between the stars. Any tips how to make my code better?
Hi!
Try adding stars not through content "" , but make a new block for them and add img there, and for this block make display flex so that your stars align horizontally
any comment so I can improve my skill thank you
Great work!
Here are some changes to your code
Use more descriptive class names instead of generic ones like "btn" or "img"
Fill alt atribute
Hope you find this feedback helpful!
I had so much fun doing this project I'll appreciate any suggestion to make my code better :)
Great work!
Here are some changes to your code
1.Because the trans() function is called on both light and dark mode, you can move it outside the change event to avoid code duplication.
2.Use more descriptive names: Variable and function names should reflect their purpose. For example, instead of trans(), you can use addTransitionClass()
3.Use const instead of let for constant variables: The checkbox variable does not change after initialization, so it can be declared with const
Hope you find this feedback helpful!
I would love to see some suggestion to keep improving
Great work!
Here are some changes to your code
2.Use more declarative class names. The class names like .card, .img-container, .creation do not give any idea of what these elements represent. It is recommended that you use more specific class names that more accurately describe the elements.
3.For better readability, it makes sense to group CSS properties by type, for example defining font properties first, then colors, and so on.
Hope you find this feedback helpful!
4th Project
Any feedback about this is welcome ! 👌
Thank You ! 😁😁😁
Hello!!!
I can suggest a few improvements
1.Move all dom elements to the top of the code to have better visibility on all elements.
2.Make function names more natural init() ---> handleRatingClick()
3.I also replaced the rating variable with a number, as it is a more natural type for the rating value.
4.Also not recommend properties for the <html> tag.
Hope you find this feedback helpful!! 😉
Hello!!!
Excellent code! I can advise only one thing
Hope you find this feedback helpful!! 😉