New Version 1.1 Fixing Flexbox and the QR card
Jorge saxon
@JAsaxonAll comments
- @Tux3er-IsmaSubmitted almost 2 years ago@JAsaxonPosted almost 2 years ago
Hello! Great work! Almost pixel perfect however there are some things I would like to comment about on the code, its great that you are using class name convention! however the great thing about scss is that because you can indent style selectors inside one another, its not useful (and in fact impacts readability) to be so verbose in the class selectors as they will only apply in the local environment of the parent selector. Anyway, I'm sorry if i am being nit-picky, Nice Work!
0 - @andres-brinezSubmitted almost 2 years ago
¿Cómo se puede hacer una página Responsive con html y css?
@JAsaxonPosted almost 2 years agoHello! The size of the card should not change with the size of the screen! you should use constant measurements in either EM or PX for the width of the card. you should also try to keep media queries to a minimum and in this case they are not required at all. also if you are to use media queries you dont need to specify both a min and a max, remember that css is cascading meaning that the styles further down replace the proprieties higher up if need be, apart from that it is recommended to use variables for the colors so that you can edit them all from the same place. Apart from that ,great work!
Marked as helpful0 - @carlosbarros723Submitted almost 2 years ago
Hello, I wanted an opinion on how I can improve my techniques in css.
Thank you very much in advance.
@JAsaxonPosted almost 2 years agoIt looks great! However the text color needs to be adjusted to the ones provided as well as the font size. In the code sector there are some small issues that I found:
- I see that you used a media query, although it works great it is not really necessary as no changes need to be made on smaller devices
- Also It is preferred to use a standardized capitalization system for the class names, I would recommend either hyphenated or camel case
- Adding a class to the body element may be a bit confusing and redundant, It would be preferable to simply use the tag selector for the body
- On the subject of classes not everything needs a class! Remember that you can use child selectors like so ".container > img" as it makes it more reusable
Overall great work!
Marked as helpful0