Design comparison
Solution retrospective
For the first time I have used BEM naming convention .do let me know how can I make it better... All comments are welcome..
Community feedback
- @isprutfromuaPosted over 2 years ago
Hi there. You did a good job 😎
keep improving your programming skills
your solution looks great, however, if you want to improve it, you can follow these steps:
✅ please add transitions for buttons. It allows you to add some effect when an element changes from a state to another.
✅ don't use tag selectors. When you add CSS directly on tags, your markup can’t change. Your style is tightly coupled to your DOM, and any change increases the risk of breaking things.
✅ use code formatters (prettier, stylelint) for better code structure
✅ You Should Stop Using Pixels. They are static and aren’t truly relative to the root font-size like REM and EM units
✅ choose a naming convention , methodology, or framework and stick to it. A lot of variables have different name style
const totalPeoples = document.getElementsByClassName('left__total_peoples_input')[0] const custom_button = document.getElementsByClassName('left__button_custom')[0] const custom_input = document.getElementsByClassName('left__custom_input')[0] const message = [...document.getElementsByClassName('left__message')] const right__tip_amount = document.querySelector('.right__tip_amount > p') const right__total_amount = document.querySelector('.right_total_amount > p')
I hope my feedback will be helpful. You can mark it as useful if so 👍
Good luck and fun coding 🤝⌨️
Marked as helpful1
Please log in to post a comment
Log in with GitHubJoin our Discord community
Join thousands of Frontend Mentor community members taking the challenges, sharing resources, helping each other, and chatting about all things front-end!
Join our Discord