Design comparison
Solution retrospective
should the 'thank you card' be a new html file?
Community feedback
- @WandolePosted almost 2 years ago
Hey,
For your question: I think the "thank you" screen is fine like that! In a real project that card could be a part of a page or be a modale: it's normal to just change his content!
But you should set the 'How did we do' screen in the same card than the 'thank you' screen.
Something like:
main cardContainer howDidWeDoScreen thankYouScreen
And you toggle the display of 'howDidWeDoScreen' and 'thankYouScreen' accordingly of what you want to show.
This way you can style the 'cardContainer' for centering, size, responsive, etc. And the 'howDidWeDoScreen' and 'thankYouScreen' are styled separetly for their inner content (and the 'display' property).
In my opinion, it's easier to maintain and the html structure have more sense like that! To add even more semantic to your HTML, you could use a 'section' for the card instead of a 'div' maybe?
I hope it helps!
Edit: you made a good job I think! Just be carefull of 2 others things if you want to improve your skills:
- Don't use the
*
(except for very general rules): it can slow rendering and will make your code less readable. For example:color
andfont-family
can be set in the 'body' => The children elements will inherit the property! - When I click the submit button whitout selecting any rating, I can access the 'thank you' screen.
Like I said (and even if I made a lot of commentaries ...), you've made a really good job. I only wrote all things I think you could do to improve your project, or for future ones!
0 - Don't use the
Please log in to post a comment
Log in with GitHubJoin our Discord community
Join thousands of Frontend Mentor community members taking the challenges, sharing resources, helping each other, and chatting about all things front-end!
Join our Discord